Thursday, May 31, 2007

CCIE Voice Home lab with Dynamips/VMware

This is an attempt to simulate a decent CCIE Voice home lab on a single PC (with oodles of memory and a bleeding edge CPU).

  • What can it do?
    • Frame Relay/OSPF
    • Calls between all sites using 4 digit or full E.164 numbers
    • Full route plans using RG, RL, RP and H323 gateways or trunks
    • SRST
    • AAR
    • Voicemail integration of CCM/CME with Unity
    • IPCC (almost everything)
    • CME , COR, dial plan with 4 digit or full E.164 dialing
    • WAN QoS
    • Call manager Applications - IPMA, Ext Mob, Attendant Console
    • Gatekeepers, IPIP GW, SIP gateways and trunks
  • What doesn't work?
    • Anything that involves a DSP like transcoding, conferencing or calls with multiple codecs
    • Any type of voice port configuration - PRI or CAS, FXO/FXS, E&M..
    • Anything related to the 6500, VG248, ATA (although it might be possible to connect to an ATA externally if you are adventurous - all it needs is a DHCP address and access to CCM), specifically port configuration or QoS.
    • CUE or anything related to it
    • LAN QoS
    • MGCP
  • How is this done?
    • Four routers in dynamips, one for PSTN, one each for HQ, RS1, RS2
    • Frame relay over T1 cross-overs between all three sites
    • All four routers connected by FE to a virtual switch for H.323 traffic
    • VMware server with CCM/IPCC on one VM, Unity on another, 3 virtual networks
    • Third VM running Windows 2000Pro (XP is a hog) with 3 NIC cards
    • Multiple copies of IP Blue 'evaluation' phone on the w2k workstation for HQ, RS1,RS2, PSTN phones.
    • Basic configurations as detailed below for all routers.
    • Lots and lots of memory and a bleeding edge CPU.
    • Did I tell you lots and lots of memory and a bleeding edge CPU?
    • Patience - If all of this stuff is running at once, this thing will be crawling - start up only the stuff you need, and it will rock!

Following is a diagram of how it is all set up


  • VMware is set up with three network adapters vmnet1,vmnet2 and vmnet3 with ip addresses as 10.101.1.1/24, 10.102.1.1/24 and 10.103.1.1/24
  • HQ, RS1 and RS2 connected to PSTN via T1 crossover and frame-relay encapsulation
  • HQ, RS1 and RS2 routers has their fa0/0 interface with 10.[101/102/103].1.254
  • HQ, RS1 and RS2 routers has the loopback0 with 10.[11/12/13].1.254
  • PSTN, HQ, RS1 and RS2 has their fa0/1 interface as 10.100.1.[1/2/3/4]
  • HQ, RS1 and RS2 has VOIP dial-peers with 'session-target ipv4:10.100.1.1'
  • PSTN router has CME enabled and the extensions 911,101xxxyyyy,202xxxyyyy, 303xxxyyyy and so on..
  • PSTN router has VOIP dial peers pointing to the appropriate router for the extensions that belong at that site, for example 'session target ipv4:10.11.1.254' for 'destination-pattern 101xxxyyyy'
  • CME with B-ACD on the RS2 router
  • SRST with AA on the RS1 router
  • IPIPGW must be running on the HQ and RS1 routers - here's why. CCM will have HQ and RS1 routers configured as H.323 gateways - so the call to "PSTN" is a call to the H.323 gateway, which hits the router and.. the router in turn sends the call over h.323 to the "PSTN" simulator. So, the call has two h.323 legs to go one way - 'voice service voip, allow connections h323 to h323' - sound familiar? :-)
Forgot to mention one key part - My laptop is not running Windows - I am a long time Linux fan and is running Slackware 11.0, VMware server 1.0.3 on a Dell D620 with dual Centrino and 2GB of RAM.

That's pretty much what I can think of now.. Configs are included below to have the basic connectivity going as mentioned above. Rack your brains to build out the rest.

There are excellent notes by people elsewhere on the net on how to get CCM installed in a VM, how to launch multiple IP blue phones simultaneously (speaking of IP blue phones, I will write up another tip for getting multiple of those phones running quickly and post it here next), et cetera, et cetera..

Standard Disclaimers, just to avoid any hard feelings going forward :-)

I CANNOT provide you IOS images or CCM/IPCC software, All the trademarks and references of any of the commercial/ non commercial software/hardware referenced in this post are the properties of their respective owners and I do not claim any rights to them whatsoever... and last but not least, I am not responsible for anything that results directly or indirectly from following my instructions here - anything at all including but not limited to 'your computer blowing up' or 'your girlfriend/wife leaving you since you got hooked to VMware or dynamips'.

Three cheers for dynamips , dynagen and VMware.. and good luck for those who are working on their CCIE Voice labs!!

Dynagen .NET file for the network section :

I used 2691 routers since they can do IOS with IPIPGW, Frame relay, dot1q trunks, dhcp server, CME, SRST , h.323, SIP and so on with IOS 12.4 on 128MB RAM. The IOS I used is c2691-adventerprisek9_ivs-mz.124-9.T1. Yes, I know that this is not the same IOS mentioned in the lab blue print at Cisco's site, but this does most of what 'wanted to learn' using this environment. The idlepc values are specific to my IOS, and might not work if you use a different IOS - I get the dynamips CPU/memory usage down to 30%/32% approximately with these values when all of the devices up and running (CPU spikes momentarily to 99% while doing 'show running' or 'write mem' though).

ghostios = True
[localhost]

[[2691]]
image = /data/tftpboot/C2691-IP.BIN
ram = 128
slot1 = NM-4T

[[ROUTER PSTN]]
model = 2691
f0/1 = S4 1
s1/0 = HQ s1/0
s1/1 = RS1 s1/0
s1/2 = RS2 s1/0
idlepc = 0x60af83ec

[[ROUTER HQ]]
model = 2691
f0/0 = S1 1
f0/1 = S4 2
idlepc = 0x61f02640

[[ROUTER RS1]]
model = 2691
f0/0 = S2 1
f0/1 = S4 3
idlepc = 0x61f02640

[[ROUTER RS2]]
model = 2691
f0/0 = S3 1
f0/1 = S4 4
idlepc = 0x61f02640

[[ethsw S1]]
1 = access 1 NIO_linux_eth:vmnet1

[[ethsw S2]]
1 = access 1 NIO_linux_eth:vmnet2

[[ethsw S3]]
1 = access 1 NIO_linux_eth:vmnet3

[[ethsw S4]]
1 = access 100
2 = access 100
3 = access 100
4 = access 100


Relevant sections of the PSTN router

frame-relay switching

interface FastEthernet0/1
ip address 10.100.1.1 255.255.255.0
speed 100
full-duplex
h323-gateway voip interface
h323-gateway voip bind srcaddr 10.100.1.1

interface Serial1/0
description HQ-RTR
no ip address
encapsulation frame-relay IETF
serial restart-delay 0
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 201 interface Serial1/1 101
frame-relay route 202 interface Serial1/2 102

interface Serial1/1
description BR1-RTR
no ip address
encapsulation frame-relay IETF
no fair-queue
serial restart-delay 0
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 101 interface Serial1/0 201

interface Serial1/2
description BR2-RTR
no ip address
encapsulation frame-relay IETF
serial restart-delay 0
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 102 interface Serial1/0 202

ip route 10.11.1.0 255.255.255.0 10.100.1.2
ip route 10.12.1.0 255.255.255.0 10.100.1.3
ip route 10.13.1.0 255.255.255.0 10.100.1.4

tftp-server flash:P00307020200.bin
tftp-server flash:P00307020200.loads
tftp-server flash:P00307020200.sb2
tftp-server flash:P00307020200.sbn

dial-peer voice 2000 voip
destination-pattern 1011111...
session target ipv4:10.11.1.254
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad

dial-peer voice 3000 voip
destination-pattern 2022222...
session target ipv4:10.12.1.254
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad

dial-peer voice 4000 voip
destination-pattern 3033333...
session target ipv4:10.13.1.254
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad

dial-peer voice 1 voip
incoming called-number .
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad

telephony-service
load 7960-7940 P00307020200
max-ephones 1
max-dn 5
ip source-address 10.100.1.1 port 2000

ephone-dn 1 dual-line
number 911

ephone-dn 2 dual-line
number 1015551111

ephone-dn 3 dual-line
number 2025552222

ephone-dn 4 dual-line
number 3035553333

ephone-dn 5 dual-line
number 55987654321

ephone 1
mac-address 0000.0000.0000
type 7960
button 1:1 2:2 3:3 4:4 5:5

gateway

Sample Site router HQ:

voice service voip
allow-connections h323 to h323

interface Loopback0
ip address 10.11.1.254 255.255.255.255
h323-gateway voip interface
h323-gateway voip bind srcaddr 10.11.1.254

interface FastEthernet0/0
ip address 10.101.1.254 255.255.255.0
speed 100
full-duplex

interface FastEthernet0/1
ip address 10.100.1.2 255.255.255.0
speed 100
full-duplex
no cdp enable

interface Serial1/0
no ip address
encapsulation frame-relay IETF
serial restart-delay 0
frame-relay lmi-type ansi

interface Serial1/0.1 point-to-point
ip address 10.200.1.1 255.255.255.0
ip ospf mtu-ignore
frame-relay interface-dlci 201

interface Serial1/0.2 point-to-point
ip address 10.200.2.1 255.255.255.0
ip ospf mtu-ignore
frame-relay interface-dlci 202

router ospf 1
network 10.200.1.0 0.0.0.255 area 0
network 10.200.2.0 0.0.0.255 area 0
network 10.101.1.0 0.0.0.255 area 0
network 10.102.1.0 0.0.0.255 area 0
network 10.103.1.0 0.0.0.255 area 0

dial-peer voice 1 voip
destination-pattern .T
session target ipv4:10.100.1.1
incoming called-number .
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad

dial-peer voice 2010 voip
destination-pattern 1011111...
session target ipv4:10.101.1.10
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad

gateway


In addition, create static routes on the workstation redirecting traffic for the HQ, RS1 and PSTN loopback interfaces through HQ router, and the CME related traffic to the CME router. This reduces delay to the PSTN phone (which again is on your w2k desktop with TFTP address pointing to 10.100.1.1)

..now let the comments begin.

138 comments:

Anthony said...

Great Work!!

Present said...

first of all good jop

it's great jop if it can be implemnetd

i have 2 questions

first how can i simulate the PSTN

second is there any additional PC's

i mean the VM is a loopback or what

thanks alot

jayanm said...

present,

Well.. it can be done. I have it running on my laptop. Check the PSTN router configuration above - it is basically simulated using h323 dial peers - the PSTN router is an h323 gateway that takes inbound calls over ip and redirects outbound calls to each site over ip.

boonchin said...

Hey jayanm,

Great work!
Just a quick question:

What do 'access 100' mean in your following config for ethsw S4?
[[ethsw S4]]
1 = access 100
2 = access 100
3 = access 100
4 = access 100

Also, is it possible to have more than 3 vmnet? The purpose is to run extra vmware instance which cater for IP Communicator at HQ/RS1/RS2/PSTN?

Thanks and best regards.

jayanm said...

If you read up the dynagen FAQ, that is a switch definition. Each port can be configured as an access port or a trunk - Here the ports are set up as access ports. In some cases the switch ports are set up only so that the router interface connected to it shows an 'up' status.

Anonymous said...

Congrates .. i believe you got ur CCIE# recently ..

jayanm said...

Thank you.. I did.

sirus said...

congrats, u draw a new big picture for me, and inspire my CCIE voice dream, thanks.

stonwealth said...

Hi Jayanm,

thanks to your explanation and config, I also got a mini ccm lab running on my laptop :-)

I am trying to find out how to run multiple copies of IP blue phone on my laptop but I cant find how to do it on google.

Can you share with us the links or instructions how this can be done? Thanks!

jayanm said...

I have added an entry for the IP blue phone tricks.. have fun!

stonewealth said...

Thanks Jayanm for sharing your IP blue phone tricks!
You are such a kind person who willingly share your knowledge with us. Really appreciate that! :-)

Chris said...
This comment has been removed by the author.
Chris said...

i stumbled upon this site and was amazed that my dream has already been made a reality way before! i have just cleared my written and is on the process of building a home lab, and this is indeed magnificent! i'm sure this will speed up my delving into the world of cisco voice solutions. i'll be starting my own laptop lab, and hope you can give me some pointers if ever i stumbled onto some problems.

thanks again for sharing!

ps: may i know where did you pass your lab exam? ^^

jayanm said...

at San Jose.

Anonymous said...

This project looks interesting. How were you able to physically connect your Dynamips on your laptop only 1Ethernet) with 4 Ethernet ports on your Server?

Anonymous said...

Great! Well Done. materials and resources are the key componemts that were missiing for CCIE voice when compared to RS. your soultion will eliminate the huge hardware requiremenst

jayanm said...

On the question about connecting 4 NICs, I created 4 VM networks - two bridged (100/100 builtin ethernet and wireless ethernet cards) and two as host only and connected the devices as shown on the picture to these networks.

Anonymous said...

I tried you OSPF/FR config and it did not work. My FR Cloud is blocking the LSA, when I do a "show ip ospf" in a router says that Backbone 0 is inactive. Did you find similar problems ?

Anonymous said...

hi, Your trick to run multiple ip blue (vtgo) with option -d did not work out. What I do is to go to DOS prompt and run /Program files /IP Blue/ VTGP/ VTGO-PC -d but is not working.

jayanm said...

The option for running multiple phones is '/d', not '-d'. It was a typo when I wrote up the entry. I will fix it now.

jayanm said...

I did not have issues with ospf, please check to make sure that the .net file has the correct interfaces connected to each other.

krishna said...

Hi Jayan,
I am facing a problem in the lab setup. My vmware network and the dynamips router fast ethernet is not communicating. Ih the virutal switch if i enter show mac switch1 i am able to see the mac address of the vware network card and the router fast ethernet. But still i am not able to communicate. I am not able to find the solution for this. Iam missing something.

Krishna.

Anonymous said...

Krishna , there are plethora of things that can be wrong , you would need to post your configs , if that is possible.

Anonymous said...

JAYANM, when I tried to configure the ephone on PSTN router, with the mac address 0000.0000.0000 it did not allow me to do it, on the other hand I could see a Ip phone (Ip blue) connected to the PSTN Cloud (CME)

Anonymous said...

I'm currently at the stage of setting up the VMWare guest Win2k image with 3 IP blue phones. However, i can install but cannot proceed to run the IP blue phones as my problem is that no audio device are detected or installed in the Win2k guest image. Does anyone know how to resolve this? I'm also curious how the 3 IP blue phones are allocated to 3 different VMnet's when they are instaled on the same Win2k host, can anyone explain further on this? Thanks!!

jayanm said...

Question about the mac-address 0000.0000.0000 on the pstn simulator, you probably have the first connected phone auto-registered to CME. Try to create the CME config manually and connect the phone only after you have preconfigured the e-phone with a mac address, which corresponds to the mac-address of the phone that you are using (ip blue?).

jayanm said...

For the 'no audio' in win2k guest, you will have to add a sound card and configure it in the guest first. Once this is done (assuming your host has a sound card to begin with), you will be able to use sound in the virtual machine. Also, you use all vmnets in the virtual machine, you must create 3 NICs in the VM, and map them to the appropriate VMnet. So essentially the guest will be connected to three networks via 3 NIC cards.

Anonymous said...

Great Work !!

I have a quick question ..

I am using VM workstation , and i could only map to a single network card by clicking : Ethernet -> custom :Specific virtual network ..

I'm still clueless on how you did mapping from a workstation to three different VMNETs configured on the vmware machine !

jayanm said...

You have to create three different virtual networks in the VMware configuration. I am used to using VMware server (it's a free download too), so I am not sure how it is configured on the workstation.. Once you have three networks configured in VMware, you must add three NICs to the guest machine, and then connect them to the virtual networks mentioned.

Anonymous said...

jayanm,

I've got this WMWare setup but I can't seem to get IP Blue Agent Login to see the sciphonexml/IPAgentInitial.jsp.

I try and log in but get an error. If I put the url in a web page, it works. Any ideas on why IP blue is choking on logging into IPCC as an agent?

jayanm said...

Are you using an IP address or the call manager's dns name in the url? This issue could mostly be due to misconfiguration in the call manager, possibly not anything to do with the IPblue phone itself. I would re-check the service configuration in CCM, as well as if the service is correctly assigned to the phone.

hris said...

Hello, jayanm,
I have a qiestion about this lab, here it is:
When i place a call from PSTN phone to CCM phone, everything is good, but when i dial a PSTN number from CCM phone, the PSTN phone rings, then connect, but CCM phone sill hear ringing tone.....the configs are exactly as yours...
Thanks in advance and best regards :

hris said...

ooh my god, i correct the problem....CCM issue :)

Ahmad said...
This comment has been removed by the author.
Ahmad said...
This comment has been removed by the author.
Ahmad said...

Jayanm,

I need some HELP...!!!!! I would like to know if I can e-mail you with some questions if you do not mind passing off your e-mail or if you prefer e-mail me at DC.Ahmad@gmail.com so I can reply.

Thanks

jayanm said...

Ahmad,

why don't you post the questions here.. that way it will be open to more people to answer.

anupam said...

[[ethsw S1]]
1 = access 1 NIO_linux_eth:vmnet1

[[ethsw S2]]
1 = access 1 NIO_linux_eth:vmnet2

[[ethsw S3]]
1 = access 1 NIO_linux_eth:vmnet3

i am in the process of setting my lab . But can someone guide me . what does this config of the dyanmips do .As per my understanding port 1 on switch is in access vlan 1 . Am i correct , what does this NIO_linux_eth:vmnet1 stand for ..

jayanm said...

Anupam,

Those three maps the switch ports to three VMNET interfaces on your host machine that runs dynamips and vmware. This is essentially like connecting your CM, Unity and IPCC servers as well as your "workstation" to various physical switches, to which the appropriate routers are also plugged into.

check the diagram out on the blog, hopefully that clears up your question.

Anonymous said...

Hi Jayanm
You have to create three different virtual networks in the VMware configuration (your earlier post)
How i can do this. is it means i add one NIC card to each vm. For example in the CM VM i add one NIC and use custom and select vmnet1 and add one NIC in unity and use custom and select vmnet2? is it?
Cheers
Chand

Anonymous said...

Hi Jayanm
i copy paste your dynamips config and created a file called vlab0.net. modified the image file name and location accordingly
do i have to copy this vlab0.net file to any specific directory? i am using ubuntu 7.10.
i copied the vlab0.net to simple1 directory and when i run the dynagen vlab0.net i get this error. but i can run the simple1.net without any problem. any inputs?

root@ansar-desktop:/opt/dynamips/dynagen-0.10.1# dynagen vlab0.net

Reading configuration file...

Shutdown in progress...
Shutdown completed.
eth_get_dev_index: SIOCGIFINDEX: No such device
eth_init_socket: bind: No such device
eth_get_dev_index: SIOCGIFINDEX: No such device

*** Error: 206-unable to create Linux raw ethernet NIO
Shutdown in progress...
Shutdown completed.

cheers
Chand

jayanm said...

Chand,

For your first question, just connecting to vmnet1 or vmnet2 will not be enough. Under Linux (I have always used the .tar.gz versions of vmware, not rpm), run the vmware-config.pl command as root, and choose to configure 'host only networks and provide appropriate subnet information for them as mentioned in my post.

For the 'eth_get_dev_index: SIOCGIFINDEX: No such device' error:
You must have 'libpcap' installed for using raw eth devices. Also, dynagen must be run as root to be able to connect to raw ethernet device.

Anonymous said...

Hi Jayanm
You are the Man.. i just run the vmware-config.pl and selected the host. almost my setup is up now. my system cpu is almost 100%.. i am using intel E6850 with 8gb of memory. i think i should have bought qx6850..
i try not to bug u but it will take some time to complete the PSTN h323 moving..I am thankful for your time and replies.

Chand

Ganjo said...

Hi Jayanm
Firt of all thank u so much for posting this information.This has been really helpful to set up a voice lab at home.I manage to build a basic lab with no pstn router in it.But i am facing a problem making my phones registered to ccm to communicate with the remote phones which are registered to the cme.Is it ok with you if you can give me your mail-id as i could send you the configuration i have done.Posting it here would make it too lengthy.

Thanks in advance

Ganesh R

Anonymous said...

All,

I have a question about CME. When I run CME with the IOS versions that I have in Dynagen I get a limited set of functions for
Router(config)#ephone-template 1
Router(config-ephone-template)#?
Ephone template configuration commands:
default Set a command to its defaults
exit Exit from ephone-template configuration mode
no Negate a command or set its defaults
softkeys define softkeys per state

the IOS versions that I have are:
c3725-adventerprisek9-mz.124-7.bin
c3640-ik9o3s-mz.124-10.bin

The version of cme is 3.3 when I do a show telephony-service command.

Is this what I should expect from CME running under Dynagen or is there something else I need to do to get the full set of commands?

jayanm said...

On the question about CME..

Did you try with an IOS that has the Voice over IP feature set. I am not sure if 'adventprise' includes that.

Also, did you run the telephony service setup?

jayanm said...

Ganesh,

For the CCM phones to communicate to CME, you need to have one of two things - either an intercluster trunk configured between them, with appropriate dial plan configuration or both of them registered to a gatekeeper with appropriate prefixes configured.

This is a broader topic than can be addessed in quick note like this.

Anonymous said...

I used the 'adventprise' as you specified in your article above for the 2691 except I used a 3725 instead. Not sure why the model would make a difference. Does your 2691 have more than four items listed when you issue the command that I used below? Router(config-ephone-template)#?

I have noted as well that I only have the following commands available to me on dynagen:

Router(config)#ephone?
ephone ephone-dn ephone-hunt ephone-template

but the following commands are available on the one at work:

Router(config)#ephone?
ephone ephone-dn ephone-dn-template ephone-hunt
ephone-template

>Also, did you run the telephony >service setup?

Yes. If you don't do this then you will get the response from your router that you need to enable telephony-service and it will not tell you what version you are running.

What version of CME does your router report running the 2691 software? You can get this by typing show telephony-service.

Thanks,

ss

jayanm said...

ephone-template only has the options that you mentioned.. I don't think anything is missing there.

The ephone - phone definition - and ephone-dn - line definition - commands have more options though.

Anonymous said...

Thanks I figured out what the problem was and found the commands I was expecting.

ss

Anonymous said...

Jayanm,

When did you pass your IE Voice?

How many attempts did it take?

In taking the test what strategy do you think worked best to pass the test?

Anonymous said...

nice work

Anonymous said...

Would this setup be useful to build up Speed to get ready for the LAB ?

jayanm said...

Depends.. not all technologies in the lab blue print on cisco.com can be simulated using this environment. So you can understand and learn some of the technologies using this lab, but will not be able use this as the only tool for learning or improving your speed.

Anonymous said...

first of all

thanks JAYANM for u'r patient and

high response for the questions

i'm impressed for u'r great work

and i hope u be patient with me

and explain me some questions

===================================

Q1:this scenario is based on IP to IP GW "correct me if wrong"

so what is the difference if we

have a group of phones "may be

some of them in remote sites"

connected directly to CCM and have

a calls between CCM phones

===================================
Q2: how u connect the CME and CCM
===================================

Q3:the last question and the most

important Q for me because a

small knowledge in the VMWARE

my question is

lets say i create VMnet1 & 2 & 3

all the VMnet are located in ONE

XP or 2000 or linux HOST

and i have ONE NIC card so can i

use CCM & DYNAMIPS(HQ and or RS1)

and one PHONE per CCM and HQ or

i must create a new VMWARE"XP OR

other OS" please explain me that

finaly i'm so sorry for my bad

english and thanks for u'r time

Anonymous said...

I can make the ip blue boot with multiple instances, any tips? (/d included)

Anonymous said...

Great! I am working to setup this lab, but I have a question, does 2691 support NM-16ESW ?? because I need an extra Ethernet port on R1. thanks

jayanm said...

Q1:this scenario is based on IP to IP GW "correct me if wrong"

>>>>
The IP to IP gw in the scenario is only because the PSTN is a H323 simulation, as well as the gateways connecting to CCM. MGCP would not work since there are no 'physical voice devices (PRI/FXS/FXO). H323 to H323 would require IP to IP GW.

===================================
Q2: how u connect the CME and CCM

>>>>>
Either an intercluster trunk or using H323 gateways to a gatekeeper.

Q3:my question is vmnet etc..

you can create upto 9 vmnets, with host only networks. that should be enough for the scenarios mentioned here.

Anonymous said...

Hi,

I have installed dynamips + dynagen and Vmware and when I try to ping from on router the vmnet, ,arp are complete, but when from linux, I would like to ping the IP adress of the router, the arp is incomplete.

The router (default in Dhcp) get an ip adress from the Vmnet inetrace, but I can not ping.

Did you have the same behavior ?

many thanks,

alban

Moty said...

Hello jayanm

congrats on passing your CCIE voice Lab, and great post on how to simulate all this stuff togather.

may i ask you what material you used?? what training material did you used?

this will help in the IP addressing designing for this lab.

regards

Anonymous said...

Jayanm, I've spent almost 5 weeks trying to make this setup to work. Everything worked fine but I could ever make the BR1 phones to get registered. When using IP Blue phones in BR1 they registered but unregistered after a few minutes. I plug 2-7960 and they never registered except for once but it quickly unregistered again. I used Network Monitor in Callmanager and I could not see the DHCP request coming in.
Any ideas ?
AA

Anonymous said...

Jayan

Hi,

I have a question.
I spent 6 days to get IPCC working on my CCM Vmware images ... and it's still not working ... Maybe you can help me with setting this up?

I am almost there to start ... but this Vmware thing is so timeconsuming that I don't have time for the actual study :-(

Thanks in advance for you help

-Iwan
maybe you can contact me at
iwan [at] i-1.nl

jayanm said...

AA,

Sorry I missed your post.. you probably have figured this out by now, but the Branch phones will need a 'ip helper address' on the router to direct them to the dhcp server, or dhcp configured on the router with option 150 pointing to CCM.

dc said...

Hi Jayman,
Thanks for your great work.
I have one question about this voice lab. I already create similar topology like yours, except i create it under windows platform. I tested by registering IP Comm in HQ site and BR1 site. Both IP Comm can registered smoothly but when i try to call between HQ and BR1 something weird happened. There are a long delay between HQ and BR1 call (call setup, call teardown, i also got Request time out when try to ping CCM Server). I have tried to change the connection using ethernet (between HQ and BR1) and it work smoothly. Do you have any idea why this happened? thank a lot.

jayanm said...

Latency can be a big issue with these connections, since the machines are severely taxed with sharing CPU and memory resources.

Again, I would use Linux for anything involving VMware/Dynamips etc..I have had better luck with that. Windows and 'efficent use of resources' somehow seems like an odd combination - like most M$ techies say "Wait until Windows N+1, where N is the current year".

Anonymous said...

very nice posts..

on your dynamip .ini file , shud
there be a section on [[frsw]]as well in order to map the dlcis

Bala said...

Hi, when I try B-ACD script in RS2 it give the following error "%CALL_CONTROL-6-APP_NOT_FOUND:", could please let me know in dynamips B-ACD script is possible or I am missing any config.

My Config as follows:
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
no supplementary-service h450.2
no supplementary-service h450.3


ephone-hunt 1 longest-idle
pilot 1111
list 4001, 4002
timeout 10



ephone-hunt 2 longest-idle
pilot 2222
list 4101, 4102
timeout 10



application
service queue flash:app-b-acd-2.1.0.0.tcl
param number-of-hunt-grps 2
param aa-hunt2 1111
param aa-hunt3 2222
param queue-len 15
param queue-manager-debugs 1

!

service aa flash:app-b-acd-aa-2.1.0.0.tcl
paramspace english index 1
paramspace english language en
paramspace english location flash:
param service-name queue
param handoff-string aa
param aa-pilot 8005550123
param welcome-prompt _bacd_welcome.au

param number-of-hunt-grps 2
param dial-by-extension-option 1
param second-greeting-time 60
param call-retry-timer 15
param max-time-call-retry 700
param max-time-vm-retry 2
param voice-mail 5003

!

dial-peer voice 222 voip
service aa
destination-pattern 8005550123

session target ipv4:192.168.1.1
incoming called-number 8005550123
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad


---------------------------
B-ACD script are upload in Image folder

jayanm said...

Bala,

It is certainly possible to do that. I would re-check the location and name of the application in flash. I will try this code in dynamips and post the results here .

jayanm said...

I tested it now and it works fine.. The only thing I can think of is that you have the file in the wrong location - flash:app-b-acd... means that the file is on the root directory of flash: . If you have placed the files under a subdirectory, try moving them to the root, or changing the parameter to point to the right location.

CS said...

Does this lab works on Cisco 2600 router with c2600-adventerprisek9_ivs-mz.124-17 IOS?

jayanm said...

Not sure of which hardware or IOS it will work with.. The design is based on dynamips, so any router that can include the number and type of interfaces in the design, as well as an IOS that supports all of the Voice functions should work.

I don't know if advent includes all voice/h.323 functionality. Please check Cisco's site to see the available functionality on that IOS.

Richard said...

Jayanm et al,

There is a nice video created by Josh at:
BlindHog.Net about installing CUCM version 6.x in VmWare.

Anonymous said...

is it possible to do AAR between HQ and branch based on this VM lab here.Can anybody provide any guidance on this.? Thanks....

ciscoforever said...

Hello jayanm,
I tried to follow your advise for IP blue, running IPBlue over WINXP.
The IP blue is 2.10.105.

I got 2 problems :

- first phone register normal, second one after importing the registry file, the phone register as if the first one.

- I configured several IP's for each VMnet NIC card, but both phones are registered with the 1st MAC address.

ciscoforever said...

Hello jayanm,
I tried to follow your advise for IP blue, running IPBlue over WINXP.
The IP blue is 2.10.105.

I got 2 problems :

- first phone register normal, second one after importing the registry file, the phone register as if the first one.

- I configured several IP's for each VMnet NIC card, but both phones are registered with the 1st MAC address.

jayanm said...

Please follow instructions show here..
http://corner-il.blogspot.com/#ipblue

See if there are any differences in the registry files that you create for each phone. Search for the first MAC address in the .reg files, and replace them with the correct ones if they are incorrect.

Zoro said...

Hi
First of all thanks for all the information.
I have a problem about the IP Blue phones.
I have installed a win xp with 3 nics on vmware for the blue phones.
my vmnet1 and vmnet2 are connected to the virtual switches on dynamips. vmnet0 is bridged to my real network or real nic on my pc on which ubuntu is working.

my problem is, what ever i do ( choosing different variations of mac address and nic selections on blue phone ) it always uses the ip address of the nic which is bridged to the vmnet0. i tried to disable the virtual ethernet on the vmware which is bridged to the real nic. I can ping from my BR1 router to the vmnet1 related hostonly nic on the image. whenever i start the bluephone, my ip connectivity from that nic goes down after a few pings ( even the callmanager sees that ip address but cant have enough time to register the phone ). I hope i could make myself clear and I hope you or someoneelse following this blog know the answer.

thanks

jayanm said...

Some one else had mentioned this issue before.. I will try to replicate this, but I have not had any problems before. All IP blue phones will register to call manager using the same IP address, but they all have different device/MAC address. As far as I know, that's all that matters.

I will try to test this again and post results.

shawnee said...

Hi jayanm... awesome work on your lab....

i have a question.. with something that i have been racking my brains with.. for my lab setup..

i have a HQ--site and two remote sites..

My HQ site has a 127.0/24 subnet.. with my CCM as 127.5.. and my two remote sites are 128.0/24 and 129.0/24.. the problem i am having is that i am not able to communicate with my call manager (which is on the HQ sites )subnet from my remote sites. I am running ospf with all of the WAN ip info and Lan ip info included.. please hellpppppppp :-)

Anonymous said...

CAN ANYONE HELP ME ON RUNNING MULTIPLE INSTANCE OF IP-PHONE ON MY LAPTOP.i'M USING WINDOWS XP AND WHEN I'M USING /d option it's not working can someone please tell me what exactly i have to write under run

jayanm said...

shawnee,

About your lab setup, I am not sure using 127.x addresses is a good idea. 127 subnet has a special meaning for loopback - I wouldn't be surprised that it is treated specially in the code somewhere in the many products that you are trying to integrate here for the lab.. I would try using real private IP addresses (10.* or 172.16 - 32.* or 192.168.*) and see if you can reproduce the error.

Jayan

jayanm said...

About the "/d" option - it seems to work even with the newest version of ip blue phone. It is no longer called VTGO-PC.exe. the executable is Softphone.exe. Open a command window, go to 'C:\program files\IP Blue\VTGO-PC' and run the command 'Softphone.exe /d' to test it.

Jayan

kim said...

Hi Jayanm,

sorry for the confusion. My network is setup using the 192.168.127.0/24, 192.168.128.0/24 and 192.168.129.0/24 networks. I just keep racking my brain...as to why i cant ping my host on the 192.168.127.0 network. (The host ip address is 192.168.127.5), and i am using bridged networking on my vmware machine. ...pleasee helpppppp

jayanm said...

Not being able to ping the host that you are running 'dynamips' on from a router running in dynamips is a known issue. If the host is running linux, you need to set up a bridge interface using 'brctl'.

Some of it is explained in this thread at the link below - read through it and let me know if you need help.

http://7200emu.hacki.at/viewtopic.php?t=6.

There is something similar for Windows also, but I stay away from Windows as much as I can, so you'll have to google for it..

kim said...

Hi Jayanm,

Just got your reply.. weird thing is that i am running vmware player on windows based systems.... as stated before, i have tried to use "bridging"...yet i am still unable to ping to my windows host (call manager) whose ip address is 192.168.127.5 ..from my gateway routers on dynamips.....

jayanm said...

'bridged networking' on vmware is different from the ethernet bridge that I am referring to.. please read through the forum link I had posted.

Jayan

Anonymous said...

HI JAY:

Awesome work on your part. coul you pls post any links on "CCM installation in a VM". I am googling as well. thanks,sp.

Anonymous said...

great job jayanm, anyone with the full configs for the remote sites for this lab

Anonymous said...

My Ipblue failed to registered with the CME on 2691.
I installed dynamip/2690 and my blue is running on the windows XP.

No Vmware at all.

should I troubleshoot this setup or run blue on VMware host?

Thanks..

jayanm said...

No, you don't have to run IP blue from vmware, it can be on a real host - if you have real phones on a physical network, you can even have them register to CME on dynamips. Make sure the machine where IP blue is running can ping the router running in dynamips.

malaka said...

The log says it download correct xml file etc, but it cycle through registration process and many successful download instances are there in every minute.
(MAC, IP etc are perfect as i see in the blue display)

This is my config,
I am taking too much time from you.

telephony-service
max-ephones 5
max-dn 10
ip source-address 11.0.0.175 port 2000
create cnf-files version-stamp 7960 Oct 16 2008 14:50:16
max-conferences 4 gain -6
!
ephone-dn 1
number 8888
!
ephone 1
mac-address 001D.0928.04F1
type 7960
button 1:1
!

jayanm said...

Are you running one instance of the phone or trying to do multiple phones? If you are trying to do multiple, please read my blog entry for the IP blue phones on the same page.

Also, make sure you have the correct phone type specified in IPblue - you have selected 7960 for the CME e-phone definition.

I think IPblue defaults to 7940.

malaka said...

related to the same posting
"The log says it download correct xml file etc, but it cycl"

do I need to have license for cme? I installed [c2691-ipvoicek9-mz.124-13b.bin]only.

running single blue and model is also correct.

Ran a sniffer and traced some thing like " no license"

jayanm said...

you do not need a license technically to get it to work in your lab. You of course need a license to use it in production.

Can you post your CME router configuration - all of it?

Anonymous said...

HI,

First of all let me thanks the author for putting up the great work. I just attempted the lab at SJ (Failed) but this post was an excellent help in my preparation. Remote labs were OK but good, reliable internet connection was a problem, so most of the things I practiced at my home lab which I had built with the help from here.

Couple of things I need help on are following:

1) Does the dynamips virtual-switch support Multicast? I could never make it work. Has anyone able to make MOH work on Dynamips/VMWare simulated lab? I am using all IP Blue/IPC phones.

2) BR2 CME, IP phones (IP Blue & IPC) keeps on unregistering/registering. Does anyone know fix for this? I've tftp server and load command in place.

3) One surprising issue I faced at Lab was MGCP gateway not receving the caller name from CCM. I had done that hundered times and was surprised to see this. This time I am planning to put up couple of routers with VWIC so that I can actually practice on all PSTN issues. I am seeing 1760 are real cheap now. Can someone comment if buying 1760 for a home CCIE voice lab is a good deal? I can increase memoery and put CME as well if I want. I really don't see any problem but want to take some more opinions.

Thanks for your time

jayanm said...

I am glad this helped you with your learning - Good luck with your next try.

On your questions:

1) I have not tried multicast specifically on the dynamips switches, but I don't see any reason why it would not work. And MOH, as well as the TCL scripts for autoattendants does work in dynamips, make sure that the name of the MOH file is right (if done on the router) and it is present in flash.

2) The CME phones unregistering could be the simulated routers losing connectivity probably due to heavy CPU utilization. There is a software called cpulimit that lets you limit the CPU usage per process (I have used it on Linux, not sure if it works on windows). you should probably try to put some per process cpu limits so dynamips/vmware is not trying to compete for CPU and your machine is having a hard time keeping up. If possible, I would suggest that you run this on a Linux machine - I am no fan of windows for anything besides games or browsing those fancy 'only works on internet exploder' sites :-) - or when work requires me to use Visio - haven't found a way around that yet.


3) 1760s are not bad for home labs. Make sure you have enough RAM/Flash to load the right IOS that supports the voice features and DSPs if you are putting VWICs in them. I am not sure if you will need NM-HDVs to put VWICs in them though.

Anonymous said...

Thanks for your reply:

1) I could make TCL scripts work on Dynamips but never multicast MOH. We need to configure IGMP snooping on Cisco switches to make Multicast work and Dynamips virtual switches are not configurable that's why I am wondering if Multicast is actually supported or not. I am planning to run HSRP to see if Multicast packets are being forwarded across Dynamips virtual switches or not.

2) Actually, IPC and IP Blue registers fine. Only problem when BR2 switches over to SRST both IPC and IP Blue keeps on registering/unregistering. Not sure why.

3) I checked and found 1760 need PVDM-256K which is configured very much like old PVDMs. It seems good bet.

thanks once again for your efforts and time..

chikkis said...

Hi Jayanm,

I am thanks for the Various post you have put. They been very help. However i have been able to recreate the Cisco CCIE voice LAB Completely.
followin are the features i have not been able to achive yet.
1. SRST.
2. AAR.
3. MGCP.
4. SIP trunking or SIP enablement.
5. IPIPGW.
6. WAN QoS.

Mainly the GNS3 Part is not complete.

I have been able to install and integrate the following.
CUCM 4, 5, 6, 7. On VMWare

Unity Manager 5 Win2k3 on VMWare.
Unity Connection 6 on VMWare.

CCME4.3 on 3725

Phones 7961 (IP Blue), 7971 (CIPC)

Please i need HELP on the some of the impelementation of the lab part.
Maily SRST and AAR on the GNS3.

I would be very thankfull if you could buzz me on my yahoo

Thanks and Regards,
Chikkis
chikkiv@yahoo.com

Chikkis said...

Hi Jayanm,

I am thank full for the Various post you have put. They been very help. However i have been able to recreate the Cisco CCIE voice LAB Completely.
followin are the features i have not been able to achive yet.
1. SRST.
2. AAR.
3. MGCP.
4. SIP trunking or SIP enablement.
5. IPIPGW.
6. WAN QoS.

Mainly the GNS3 Part is not complete.

I have been able to install and integrate the following.
CUCM 4, 5, 6, 7. On VMWare

Unity Manager 5 Win2k3 on VMWare.
Unity Connection 6 on VMWare.

CCME4.3 on 3725 Router

Phones 7961 (IP Blue), 7971 (CIPC)

Please i need HELP on the some of the impelementation of the lab part.
Maily SRST and AAR on the GNS3.

I would be very thankfull if you could buzz me on my yahoo

Thanks and Regards,
Chikkis
chikkiv@yahoo.com

Chikkis said...

Hi Jayanm,

I am thank full for the Various post you have put. They been very help. However i have been able to recreate the Cisco CCIE voice LAB Completely.
followin are the features i have not been able to achive yet.
1. SRST.
2. AAR.
3. MGCP.
4. SIP trunking or SIP enablement.
5. IPIPGW.
6. WAN QoS.

Mainly the GNS3 Part is not complete.

I have been able to install and integrate the following.
CUCM 4, 5, 6, 7. On VMWare

Unity Manager 5 Win2k3 on VMWare.
Unity Connection 6 on VMWare.

CCME4.3 on 3725 Router

Phones 7961 (IP Blue), 7971 (CIPC)

Please i need HELP on the some of the impelementation of the lab part.
Maily SRST and AAR on the GNS3.

I would be very thankfull if you could buzz me on my yahoo

Thanks and Regards,
Chikkis
chikkiv@yahoo.com

Chikkis said...

Hi Josh,

I am thank full for the Various post you have put. They been very help. However i have been able to recreate the Cisco CCIE voice LAB Completely.
followin are the features i have not been able to achive yet.
1. SRST.
2. AAR.
3. MGCP.
4. SIP trunking or SIP enablement.
5. IPIPGW.
6. WAN QoS.

Mainly the GNS3 Part is not complete.

I have been able to install and integrate the following.
CUCM 4, 5, 6, 7. On VMWare

Unity Manager 5 Win2k3 on VMWare.
Unity Connection 6 on VMWare.

CCME4.3 on 3725 Router

Phones 7961 (IP Blue), 7971 (CIPC)

Please i need HELP on the some of the impelementation of the lab part.
Maily SRST and AAR on the GNS3.

I would be very thankfull if you could buzz me on my yahoo

Thanks and Regards,
Chikkis
chikkiv@yahoo.com

jayanm said...

SRST and AAR has nothing to do with GNS3. Make sure the IOS you are using has support for SRST. AAR configuration is exclusively done through Call Manager and does not involve configuration on the router.

MGCP will NOT work with the virtual lab environment - MGCP works by utilizing router hardware configuration - PRI or T1 or analog ports.

SIP trunking, IPIPGW and WAN QoS does work, although the QoS configuration can yield poor results in the virtual router environment.

Chikkis said...

Hi Jayanm,

I am using "c3725-adventerprisek9-mz.124-15.T5.bin" as my ios for all the routers.

here are some other posts which i have been following.

Voice Lab - Headquarters build
http://www.blindhog.net/voice-lab-headquarters-build/

Voice Lab - Frame-Relay WAN
http://www.blindhog.net/voice-lab-frame-relay-wan/

but i dont kown how will be connecting my phones and registering my phones to the CUCM.

following the configration i have done following the posts above. from here i how do go further i am not able to understand.

en
conf t
hostname R2
interface f0/0
ip address 192.168.2.20 255.255.255.0
no shut
exit
exit


en
conf t
int s0/0
no shut
encapsulation frame-relay
int s0/0.1 point-to-point
ip address 192.168.5.1 255.255.255.252
frame-relay interface-dlci 101


int s0/0.2 point-to-point
ip address 192.168.5.5 255.255.255.252
frame-relay interface-dlci 102
exit
exit
exit


show frame-relay pvc
wr


88888888888888888888888888888888888888888888888888888888888888888888888888888888888888888888888888

en
conf t
hostname R3
interface f0/0
ip address 192.168.2.30 255.255.255.0
no shut
exit
exit

en
copy run flash:

format flash:

archive tar /xtract tftp://192.168.2.11/cme-full-4.3.0.0.tar flash:


en
conf t
ntp master
ip http server
ip http path flash:gui/
telephony-service
Web admin system name cmeadmin password chikkis1
Dn-webedit
Time-webedit
ip source-address 192.168.2.30 port 2000
Max-dn 15
Max-ephone 15
moh flash:music-on-hold.au
multicast moh 239.1.1.1 port 2100


tftp-server flash:/phone/7941-7961/apps41.8-3-2-27.sbn alias apps41.8-3-2-27.sbn
tftp-server flash:/phone/7941-7961/cnu41.8-3-2-27.sbn alias cnu41.8-3-2-27.sbn
tftp-server flash:/phone/7941-7961/cvm41sccp.8-3-2-27.sbn alias cvm41sccp.8-3-2-27.sbn
tftp-server flash:/phone/7941-7961/dsp41.8-3-2-27.sbn alias dsp41.8-3-2-27.sbn
tftp-server flash:/phone/7941-7961/jar41sccp.8-3-2-27.sbn alias jar41sccp.8-3-2-27.sbn
tftp-server flash:/phone/7941-7961/SCCP41.8-3-3S.loads alias SCCP41.8-3-3S.loads
tftp-server flash:/phone/7941-7961/term41.default.loads alias term41.default.loads
tftp-server flash:/phone/7941-7961/term61.default.loads alias term61.default.loads

tftp-server flash:/phone/7970-7971/apps70.8-3-2-27.sbn alias apps70.8-3-2-27.sbn
tftp-server flash:/phone/7970-7971/cnu70.8-3-2-27.sbn alias cnu70.8-3-2-27.sbn
tftp-server flash:/phone/7970-7971/cvm70sccp.8-3-2-27.sbn alias cvm70sccp.8-3-2-27.sbn
tftp-server flash:/phone/7970-7971/dsp70.8-3-2-27.sbn alias dsp70.8-3-2-27.sbn
tftp-server flash:/phone/7970-7971/jar70sccp.8-3-2-27.sbn alias jar70sccp.8-3-2-27.sbn
tftp-server flash:/phone/7970-7971/SCCP70.8-3-3S.loads alias SCCP70.8-3-3S.loads
tftp-server flash:/phone/7970-7971/term70.default.loads alias term70.default.loads
tftp-server flash:/phone/7970-7971/term71.default.loads alias term71.default.loads

telephony-service
load 7941 SCCP41.8-3-3S.loads
load 7961 SCCP41.8-3-3S.loads
load 7970 SCCP70.8-3-3S.loads
load 7971 SCCP70.8-3-3S.loads
create cnf-files


exit

ephone-dn 2 dual-line
number 4003
exit

ephone 2
mac-address 0050.56C0.0001
Type 7961
button 1:2
exit
exit

Show ephone

en
conf t
int s0/0
no shut
encapsulation frame-relay
int s0/0.1 point-to-point
ip address 192.168.5.2 255.255.255.252
frame-relay interface-dlci 202
exit
exit
exit


show frame-relay pvc

wr

Ping 192.168.5.1

88888888888888888888888888888888888888888888888888888888888888888888888888888888888888888888888888

en
conf t
hostname R4
interface f0/0
ip address 192.168.2.40 255.255.255.0
no shut
exit
exit

en
copy run flash:


format flash:

archive tar /xtract tftp://192.168.2.11/cme-full-4.3.0.0.tar flash:


en
conf t
ntp master
ip http server
ip http path flash:gui/
telephony-service
Web admin system name cmeadmin password chikkis1
Dn-webedit
Time-webedit
ip source-address 192.168.2.40 port 2000
Max-dn 15
Max-ephone 15
moh flash:music-on-hold.au
multicast moh 239.1.1.1 port 2100


tftp-server flash:/phone/7941-7961/apps41.8-3-2-27.sbn alias apps41.8-3-2-27.sbn
tftp-server flash:/phone/7941-7961/cnu41.8-3-2-27.sbn alias cnu41.8-3-2-27.sbn
tftp-server flash:/phone/7941-7961/cvm41sccp.8-3-2-27.sbn alias cvm41sccp.8-3-2-27.sbn
tftp-server flash:/phone/7941-7961/dsp41.8-3-2-27.sbn alias dsp41.8-3-2-27.sbn
tftp-server flash:/phone/7941-7961/jar41sccp.8-3-2-27.sbn alias jar41sccp.8-3-2-27.sbn
tftp-server flash:/phone/7941-7961/SCCP41.8-3-3S.loads alias SCCP41.8-3-3S.loads
tftp-server flash:/phone/7941-7961/term41.default.loads alias term41.default.loads
tftp-server flash:/phone/7941-7961/term61.default.loads alias term61.default.loads

tftp-server flash:/phone/7970-7971/apps70.8-3-2-27.sbn alias apps70.8-3-2-27.sbn
tftp-server flash:/phone/7970-7971/cnu70.8-3-2-27.sbn alias cnu70.8-3-2-27.sbn
tftp-server flash:/phone/7970-7971/cvm70sccp.8-3-2-27.sbn alias cvm70sccp.8-3-2-27.sbn
tftp-server flash:/phone/7970-7971/dsp70.8-3-2-27.sbn alias dsp70.8-3-2-27.sbn
tftp-server flash:/phone/7970-7971/jar70sccp.8-3-2-27.sbn alias jar70sccp.8-3-2-27.sbn
tftp-server flash:/phone/7970-7971/SCCP70.8-3-3S.loads alias SCCP70.8-3-3S.loads
tftp-server flash:/phone/7970-7971/term70.default.loads alias term70.default.loads
tftp-server flash:/phone/7970-7971/term71.default.loads alias term71.default.loads

telephony-service
load 7941 SCCP41.8-3-3S.loads
load 7961 SCCP41.8-3-3S.loads
load 7970 SCCP70.8-3-3S.loads
load 7971 SCCP70.8-3-3S.loads


create cnf-files
exit


ephone-dn 1 dual-line
number 4004
exit


ephone 1
mac-address 0016.17AA.147C
type cipc
button 1:1
exit
exit


Show ephone

en
conf t
int s0/0
no shut
encapsulation frame-relay
int s0/0.1 point-to-point
ip address 192.168.5.6 255.255.255.252
frame-relay interface-dlci 203

exit
exit
exit

show frame-relay pvc

wr

Ping 192.168.5.5

Bruce said...

I was very excited to try this, but believe that it is not possible to bridge the Dynamips/Dynagen network to VM Fusion images on the MAC platform. I updated a post on the Dynamips forum with the details.

http://7200emu.hacki.at/viewtopic.php?t=6069

I have not received any responses to this post yet, but would love to find a way to make this work on my Mac.

jayanm said...

Are you running dynamips with an account that has superuser (root) privileges?

Bruce said...

Last login: Thu Jan 1 05:41:38 on ttys000
>>Are you running dynamips with an account that has superuser (root) privileges?

Yes, the install seems to take care of that, when the application is launched on the Mac, this dialog occurs;

cd /tmp ; sudo /Applications/Dynagen/dynamips -H 7200
Macintosh:~ bruce$ cd /tmp ; sudo /Applications/Dynagen/dynamips -H 7200
Password:
Cisco Router Simulation Platform (version 0.2.8-RC2-x86)
Copyright (c) 2005-2007 Christophe Fillot.
Build date: Nov 11 2007 11:11:35

edwin said...

may i message you privately via email? i want to ask about my topology so i can give you the image and you'll understand the problem.

my email: berlowin@yahoo.com

thank you very much

Anonymous said...

Got a question plz, if PSTN router is connecting all 3 sites FR over OSPF, then why are we still connecting them all with the Fastethernet?

your help is appreciated.

saahib said...

with PSTn connecting to all 3 sites via fr/ospf, why are we connecting it through fasthethernet switch to all sites?

jayanm said...

saahib,

The serial links to pstn router from others do not allow you to route to it. They are frame relay links that let the other routers communicate between themselves, and does not provide a routed interface to the PSTN router. The Fast Ethernet links allow other routers to connect to the PSTN router for H323.

Saahib said...

First of, Thanks for replying. I have an issue creating SRST scenario since everything is WAN based. A call between Branch A and HQ completing via PSTN makes HQ accessible to the branch router and hence CCM is accessible to Branch router which kills the SRST. On the other hand if I cut off link between ccm and HQ then HQ phone is all isolated can't even reach PSTN. I wonder how the SRST is achieved. Your input is highly appreciated.

jayanm said...

Saahib,

There is a small tweak that can be used to test SRST, that is fairly easy to implement. You can create an access list on the branch router which denies access to the Call Manager (ONLY) from that router. For example, if your call manager is 10.100.1.10, branch/SRST router is 10.200.1.1, and all the phones at the branch are in the subnet 10.200.2.0/24, here is what you do:

Create an access list on the SRST router:

access-list 110 deny ip 10.200.2.0 0.0.0.255 10.100.1.10 0.0.0.0
access-list 110 deny ip 10.200.1.1 0.0.0.255 10.100.1.10 0.0.0.0
access-list 110 permit ip any any

The last line is important, or you will kill all connections from that router to HQ.

Now, assuming Branch is connected to HQ via Serial 0/0, place the restriction outbound on that interface by using the command:

int s0/0
ip access-group 110 out

This will prevent any packet from the phones or the SRST router from getting to the Call Manager, and will initiate SRST without killing the WAN link. When you are done testing, remove the access-group and access-list.

Remember, if you have multiple call managers, all of them must be mentioned in the access-list above.

Hope this helps..

Saahib said...

Awesome! I thought about doing this but then I was trying to tweak my network design to see I could achieve this without using accesslist, however I wasn't able to, major issue I had was a bad IOS which I fixed now things are behaving much better. This clarifies it well enough, once again thanks a lot!.
Saahib

Saahib said...

One of the gentleman posted this:
-------------------------
hris said...
Hello, jayanm,
I have a qiestion about this lab, here it is:
When i place a call from PSTN phone to CCM phone, everything is good, but when i dial a PSTN number from CCM phone, the PSTN phone rings, then connect, but CCM phone sill hear ringing tone.....the configs are exactly as yours...
Thanks in advance and best regards :

October 16, 2007 1:44 AM
hris said...
---------------------------
hris said...
ooh my god, i correct the problem....CCM issue :)

October 16, 2007 1:51 AM
-------------------------------

This kind of comment doesn't help much at all, I'd appreciate if you guys can post what you did to solve the problem to help out others.

I am experiencing this too, and so far the testing I have done, found out that the initiating location cannot ping the IP address of the PSTN telephony source interface, more like routing issue since rtp streams need ip connectivity.

Moreover the call from PSTN to the HQ same phone works ok, and I've checked the CME can ping the hq phone's ip address. I don't think there is anything in the CCM out there to fix this issue.

I'd still like to seek an expert advise and see what I've found out is correct diagnosis of the issue or not.

One a second note, the connecting establishes and voice is real choppy, is this the case with all you guys, (no biggie for lab purpose) but wanted to find out whether it can be fixed or is it the limitation of the resources we are using vmware etc etc.

Regards,
Saahib.

DC said...

Hi, i would like to configure B-ACD in Dynamips and i already read your previous post. My question are:
- Where should i put the BACD tcl script and the other BACD files?
- Do i have to use TFTP to transfer the file? Actually i already tried to transfer those files using TFTP but when i check using "show flash" command the files comeup but have invalid checksum. Already tried many times but still not working.
Need your help. thank

DC said...

Hi, i would like to configure B-ACD in Dynamips and i already read your previous post. My question are:
- Where should i put the BACD tcl script and the other BACD files?
- Do i have to use TFTP to transfer the file? Actually i already tried to transfer those files using TFTP but when i check using "show flash" command the files comeup but have invalid checksum. Already tried many times but still not working.
Need your help. thank

DC said...

Hi, i would like to configure B-ACD in Dynamips and i already read your previous post. My question are:
- Where should i put the BACD tcl script and the other BACD files?
- Do i have to use TFTP to transfer the file? Actually i already tried to transfer those files using TFTP but when i check using "show flash" command the files comeup but have invalid checksum. Already tried many times but still not working.
Need your help. thank

jayanm said...

The script files must be in the flash. Also, like you have mentioned, you will use tftp to transfer them to flash. I don't understand why the checksum would be wrong - maybe there are errors on the link connecting to where your tftp server is?

Chikkis said...

Hi Jaynam,

I have been following this blog for ages. i have all components in place. but some how i am not able to make them work in syn. it looks like i am makeing some design issue. I would really appreicate if you could take some time out and have a look at my home lab. I sure THIS is an expert job. i am also sure you are one.


THANKS AND REGARDS
chikki
chikkiv@yahoo.com buzz me on yahoo so that i can walk you through the issue i am going through with my home lab.

Jay said...

DC, try erasing the flash and then load the scripts, bad checksum is no good though meaning somehow the file is not in good shape.

I got B-ACD working, but voice is choppy with pauses etc, is it possible to improve this?

Any tips are greatly appreciated.

DC said...

hi jay,
thanks for your info. but if you don't mind could you please share to me your net confg with the working bacd because i really need it for testing my bacd. thanks again for your help.

jayanm said...

Jay,

There is really not a whole lot you can do to improve sound quality in a dynamips simulated router. It is mostly dependent on the CPU resources the router is able to use. If you are running all of this on a Windows machine, wiping Windows and installing some version of linux might improve your chances of some free CPU :-)

jayanm said...

DC,

All that is required to test BACD is a single router. You would probably bridge the ethernet on your machine to a FastEth interface on the router. That should give you the needed connectivity to the router.

Anonymous said...

Hello!!! corner-il.blogspot.com is one of the most excellent innovative websites of its kind. I take advantage of reading it every day. I will be back.

Anonymous said...

Trying to understand this topology. Is all this running on one PC.

Not sure if I can run all this topology on my laptop. I'm trying to simulate a lab for ccvp on my laptop and haven't got any break through yet. Just thinking this could be the best option.

Any advice, no bucks to afford equipment on Ebay

jayanm said...

Sure.. all this can be done on a decent laptop or desktop. I don't think you need to have a full fledged lab for the CCVP exam though. CCVP is mostly focused on the theory behind VoIP, focusing on QoS, Gateways and Gatekeepers and CCM in general. If you have a good working knowledge of the above, CCVP should be fairly easy. I'd rather spend more on good books for CCVP than lab equipment. GNS3 (google it) and CCM/Unity on a VM should be enough to gain hands on experience on the topics.

Vikas Srivastava said...

Hi Jayanm ,

Thanks for the amazing information here . I built the lab and works great . I am using 3 separate (Win2000) machines for each sites (HQ , BR1 , BR2) connected via the vmnets(1,2,3) to the network .

I have some questions regarding the following :

"Third VM running Windows 2000Pro (XP is a hog) with 3 NIC cards"

-- Do I need to specify IP Addresses to each interfaces in the Win2000pro (10.101.1.15 , 10.102.1.16 ...)

-- I had such configuration before but it did not worked as expected . For example ( on win 2000pro) : If I have the VMNet2 shut, the phone at BR1 should not be able to communicate to the CUCM , but it goes out to the CUCM via VMNet1 .

Also could you please elaborate on the following

"In addition, create static routes on the workstation redirecting traffic for the HQ, RS1 and PSTN loopback interfaces through HQ router ...."

Regards

Vikas

jayanm said...

Hi Vikas,

If you have three different Windows 2000 VMs, you only need one NIC on each. They should be connected to their own local network only. I was trying to minimize the number of VMs and had to work around with three NICs on one VM.

Anonymous said...

Hi Jayanm ,

I need your advise in suggesting a PC config which would allow atleast cucm , unity connection , all the routers and 6 windows 2000 instances (limited to 128M each) run smoothly at one go on vmware .

I am thinking of an i7 930 , 4GB Ram , and 3 hardisks to lower the IO load . Would that suffice ?

Just wanted to know your experience while emulating the lab.

Thanks

Vikas

jayanm said...

You'll need probably 8GB of memory if you are planning to put all this on one box. Unity Connection especially needs a lot of memory, I believe 2GB is the absolute minimum. And all your routers will use around 128MB each. 128MB VMs for Windows 2000 also will drag them down, at least 384MB is what I would recommend for W2K vms.

Dennis said...

Hi Jayanm,
dO You know why these commands not available under ephone on CME?
is it IOS or CME or Hardware limitation?

max-calls-per-button
busy-trigger-per-button

jayanm said...

These commands were introduced in CME v4.3, IOS 12.4(15)XZ or later. So it could be because you are using an older version of the IOS/CME

Dennis said...

is there a way to upgrade CME or its packed with IOS?
i cant seem to find any other 3725 image with CME 4.3.0. Any recommendation?

BRANCH_2#sh telephony-service
CONFIG (Version=4.1(0))
=====================
Version 4.1(0)

BRANCH_2#sh ver
Cisco IOS Software, 3700 Software (C3725-ADVENTERPRISEK9_IVS-M), Version 12.4(15)T6, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport

jayanm said...

If you have a valid support contract at Cisco, you will be able to download the newer versions. 4.3 is available for IOS 12.4 or later when I checked.

Dennis said...

pls, post link for CME version that will work with the above IOS.
i upgraded to CME 4.3.0 but still showing 4.1
not sure if i did it right but i upgraded with this command

archive tar /xtract tftp://192.168.4.1/cme-full-4.3.0.0.tar flash:
can see all files in my flash.

looking at this table
http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/requirements/guide/33matrix.htm
seem like i will have to go with 12.4(15)XZ above to get 4.3.0 on 3700 router but those arent available for this platform

jayanm said...

Maybe the specific platform is no longer supported for the newer CME versions, I am not sure. Ideally, you should be able to use any IOS newer than the minimum specified, and then run the CME version that goes with it. I have not tested it though. I would suggest looking through the TAC forums or open a case to get this validated.

Dennis said...

Jay,
i need some help with final setup. i have my virtual network like yours except using ethernet for WAN instead of FR due to high latency.
This my setup. tell me if this is okay for lab simulation
PSTN runs, CME H323 GW with CM and dial peers to all sites(like in your setup)
HQ runs Gatekeeper/H323 GW with CM. dial peers to PSTN and CM only.
BR1/BR2 runs H323 GW with CM and dial peers to PSTN

All GW register with HQ gatekeeper.
BR2 also run CME with ephones register.
you maintioned "IPIPGW must be running on the HQ and RS1 routers" so i have to configure IPIPGW b/w HQ and BR1?
do you have sample configuration for IPIPGW? and is the above setup correct?
Do i need dial peer on PSTN TO CM?

Rignt now i can dial from PSTN phone to CM dn # but not the other way around
thanks

jayanm said...

ipipgw configuration is rather simple. You basically allow calls to connect between two protocols - example:

voice service voip
allow-connections h323 to h323

The above will enable a call from h323 (CM to gateway) to the next leg of the call (h323 - gateway to PSTN). The blog below at CCIEV also has some helpful notes. http://cciev.wordpress.com/2006/07/31/ipipgw-example/